Convert SMF 2.0.15 to phpBB 3.0.11

Comments/Suggestions
Post Reply
User avatar
Dude
Administrator
Administrator
Posts: 12992
Joined: Mon Sep 11, 2006 3:38 am

Convert SMF 2.0.15 to phpBB 3.0.11

Post by Dude » Sat Mar 10, 2018 8:11 pm

Because of all the problems with SMF forum software
- 5 minute delay on posting
- 5 minutes to log you into your own account and not the last person on
- shoutbox problems

I have started working on converting SMF to phpBB
starting with the converter here and if that does not work then I will try the converter mods here

not sure how long this will take, but we will see.

3/13/2018
Installed the latest version of phpBB version 3.2.2 but it did not have the install directory to make the converter work,
so downloaded the older version with the install directory but I don't have a working FPT program to upload it,

uploaded the files and had to add
php_value mbstring.http_input pass
php_value mbstring.http_output pass
to the .httpaccess

3/15/2018
it's very frustrating, I was able to create a test SMF site, and a test phpBB site and run the converter,
it looks like most things converted except for the posts, I can see the database where they are and I can see the database where I want them to go,
but the PHP command to do this just will not work. it always wants to add everything to then end and make new records, I need them added to the current records which seems to be a very difficult process for PHP.

went back to the converter and tried to see if I could figure out what was wrong with it but it just gives an error

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead

when I change the preg_replace line then it just gives another error

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace_callback(): Requires argument 2, 'Array', to be a valid callback

neither of those error message mean anything to me so I am at a loss there.

3/16/2018

I figured out if I go into cpanel I can set back the version of PHP the site is using, I changed it to PHP version 5.3 and was able to get the converter to start working,
using PHP version 7.1 it would not work.
the first run got kicked out because there was a duplicate name,
then I ran into some server problems and it started timing out.
will try again later.
Last edited by Dude on Fri Mar 16, 2018 6:31 am, edited 1 time in total.
There are only 10 kinds of people in this world,
those that understand binary and those that don't. 

Post Reply